Prerequisites

Working installations of:

Commands

Inside your Flutter project directory:

List available emulators

emulator -list-avds

Start Flutter emulator

flutter emulator --launch <name-of-emulator>

Flutter Checks

flutter doctor

or

flutter doctor -v

You don’t need Android Studio but there should be checkmarks for Flutter, Android toolchain and ocnnected device.

Connect Flutter Project to Emulator

flutter run

or

flutter run -v

Further Reading